Legacy items not working?


#1

I have legacy items death punch mark two and shotgun X mark two and neither of them fire in a ranked match


#2

Do they require ammo again?
Death punch needed rockets I think and shotgun needed bullets if they reinstated the need for ammo modules they won’t work anymore.


#3

I think they removed the ammo costs from the tooltip, but the actual items still require ammo.

In other words:

If you fused your ammo modules away, those items are just decorations now. :slight_smile:


#4

For a while a few weeks ago they were working without ammo modules. I saw others using them so I tried my Devestation Swarms and they worked. I took them off because to heavy for the lower kill rate.
That’s why I said maybe they turned back on the need for ammo modules.


#5

They turned back ammo consumtion.
I was using the bullet shark drone, because it needed no energy, on my phis build… was decent… now it needs ammo… so again useless


#6

I hope its not a sign of the upcoming ammo module reintroduction. But I have to say it really sounds like the tacticsoft way. Wait until everybody destroyed the items they have because they think the game doesnt require it anymore then introduce it so they have to buy it again. I hope thats not whats going on.


#7

Of a few possibilities,

  1. The newest update happen to use the older code that needed ammo instead of the one patched not needing it.

  2. TS want us to only use new crap not the old which in some cases is BS.

  3. TS likes to play tennis games with us thinking we are the tennis balls.