It happened again

@Alexander its new year tho and its already 2:26 am it was 1:45 am when I can still play then by the time I refreshed it lol it happened again. Please help me its new year rn and my friends need my help :frowning:

Why are you using Prod? :confused:

Have you tried using the regular link?

1 Like

It’s thesame tho

I just tried those 2 still not working

Oh… is this when your internet provider blocks it from you? :confused:

1 Like

I’ve actually been having the same problem since about 24 hours ago, I haven’t been able to access any of the Battledawn domain (so that’s prod, rc, normal).

1 Like

Try a different router/network? A double check would be using your mobile to access it on the same network and if that also doesn’t work it will confirm that its the network.

The fix is annoying.Changing router/moaning to the network guys seems to work. Nothing Alex can do from his end :confused:

1 Like

Reset the modem, tried a different router with it, tried cabled and wireless, tried from mobile (from data does work), so it’s definitely the IP/network. It’s really annoying indeed.

1 Like

I was having the same issue when i tried checking up on the world im watching to see how Vik is doing. So i just gave up

reinstalled my browser.
worked for me

I already reset the modem. Reinstall the browser, tried it in mobile but I didnt change the modem yet maybe 2-3 days lol. Nothing happened at all :frowning: so I decided to fix it on my own and this wat happned.

I hope changing router would be the best solution after all.