Issue with Clans


#1

Not sure if this is the right place to put this but I guess it’ll do.

I was the leader of the guild ‘Oni’ which is a very old clan. All my members were no longer playing so I decided to kick everyone and leave in order to disband it and remake it on an alt account as a sort of memory. However when I tried to make a new clan with the same name it said it was already taken even though there are no players in it. Furthermore when i try to search ‘Oni’ nothing comes up in the search results.

Does this mean its gone forever? I’m kind of hurt over this whole thing because it was a very fond Clan that no longer served a purpose since the merge.

This would have been a lot easier if I could have just promoted someone else to leader before leaving :confused:
Really bummed out right now.

Does anyone know if there’s a way to fix this or is it just gone forever?


#2

I made a clan in 2015/2016. Left it later on. I tried to remake it, but the name was taken even though there was no one using it. Then, a few months later I tried to make it again, and it worked. Wait like half a year, and it should work.


#3

Well Jeez that sounds promosing… not :disappointed_relieved:


#4

Try waiting until after the weekly reset of ranks etc? it may be that it clears the empty alliances at the same time?