Game breaking bug why haven't you given any attention to this

so i wanted to start a new account and i did, made a new one and i went into the first battle of the tutorial, i finished it and on the finish screen i accidentaly pressed the go back button on my mouse (it has go back and go forward page buttons) and now when i go to SM all i see is a green arrow pointing to the workshop, i go into it and then it points to a non existing close button, ive reloaded the page 3 times and i even cleared the cache.

Try clearing the site’s cookies you play Super Mechs on, this way you will be logged out (or at least the site will think). Login again, and don’t press the back button :slight_smile:
Hopefully this will work…


@Sarah247 game-breaking bug spotted

I tried to recreate it and couldn’t reproduce what happened to you.
Please clear your cache and if that doesn’t work let me know.

1 Like

i cleared my cookies as dobypeti said, and it worked!

1 Like

Maybe it was just a one-time glitch… :slight_smile:

1 Like