Don't add the damn item limit


#1

WHAT SANE PERSON WOULD IMPLEMENT A ITEM LIMIT? AND I SEE THAT YOU ARE MAKING US HAVE TO BUY MYSTICALS!

  • Revert the update, and stop the item limit
  • Keep the update

0 voters


#2

<!-- Start of offtopic part --> lmao your profile picture is gold <!-- end of offtopic part–>

Yeah, the item limit is kinda bullshit, and makes you pay with tokens for more item slots.


#3

I’m actually sort of okay with the idea of an item limit, but it really should be much higher. Like 500.

Oh, and remove fusion costs, of course. So we can actually get it under the limits before the grace period is up.


#4

^^ very important to mention that in every single post from you

(honest meant)

hehe

:monkey_face: :see_no_evil: :hear_no_evil: :speak_no_evil: :monkey:


#5

Why was item limit was implemented in the first place


#6

“To allow players to focus on a few good items, instead of hoarding a bunch of useless junk”.

^ Said by the SM Developer


#7

Yeah we never focused on the useful items and always hoarded bunch of useless junk


#8

Some other things I am really PISSED OFF about are, LEGACY ITEMS LIKE WHAT I LOVE MY GLAXUS MODELS WITH A UNDYING PASSION AND I CAN’T UPGRADE THEM? 2. I can’t get mystical huh, only by the completely terrible fusion system here. 3. Wait what, I can’t get the items I want UNDO THAT ONE UPDATE 4. EVERYTHING ABOUT THIS UPDATE. REVERT PLEASE
NOW

Edit: I am okay with fusing to get mystical, but WHY THE LEGACY CRAP? I would love to see all the legacy items be upgradeable really I would love it.


#9

Yes stop the item limit right now! Stop you don’t even play on the same ground we do!


#10

The poll says it all, LOOK AT THE PERCENTAGES


#11

I’m quoting my own self for how much shit these updates have been


#12

i cant even paint the legacy items!


#13

we should be able to upgrade our legacy items ._.

.
pls


#14

I like the idea of parts/upgrades to legacy items being obsolete.
I also like the idea of having parts to upgrade them. Maybe a legacy core?

Make a post on legacy core, I’ll support.