Can't load login page


#1

Hello BD community! I am in need of your help!

I cant load the battledawn log in page https://www.battledawn.com/client/game.php?portal=earthMarsFantasy it only shows the hours glass the loads forever. The main page of battledawn works fine, i press the green “LAUNCH GAME” button and takes me to log in page, and still doesnt load
http://prntscr.com/ktrktf

What i have tried:
Uninstalling chrome, reinstalling
Restarting, Shutting down/turning on laptop
Ran Windows Defender and all that good stuff
Specifically scanned chrome, no virus found. Every single other page works, google, youtube, etc
Restarting my wifi
Using my hotspot from my cellphone
Cleared Cache, history, cookies several times
Checked chrome for update
Checked laptop for update
Tried Microsoft Edge and Mozilla FireFox, and neither is able to even open the homepage of battledawn, nonetheless the log in page. All other sites like google, facebook, and youtube work on all 3 of these browsers


I have tried a ipconfig /flushdns as well

If anyone has anymore ideas or advice, please let me know. Battledawn works fine on my mobile, and i can log in from there
But i would much rather play and enjoy the game with the comfort and ease of a laptop.

Thank you!

Edit: I do indeed have adobe flash player, and i have BD as “allowed” to run it
This first happened during around maintenance tick (9:00 PM for me ) when BD crashes many times after for 1-2 hours is when it stopped working, but i thought the site was still down until i attempted to enter from mobile, was when i become aware it wasnt loading.


#2

i think its an ISP issue but you’ll have to email this person @Alexander


#3

did you login from mobile using the same network as your computer?


#4

Hey @EnerGY Thanks for your suggestions


I have been speaking to Alexander since yesterday, I will ask him about the ISP now
And yes, my cellphone connected to the same WiFi that my laptop uses and battledawn works fine


#5

i think i encountered the same problem and what i did was , i turned off the device that was connecting me to the internet and restarted it and it worked. Felt like BD was blocking my particular IP for some reason.


#6

Bane = Nopy confirmed


#7

image


#8

This isnt the same isp problem if you can access through mobile on the same network. That error completely blocks all sites.
Have you tried BG or RC?


#9

i am having the same issues currently though this works http://prod.battlegate.net/battledawn/portal_new/