Achievements / Tasks display bug

Since several days ago I have been unable to see my achievements in the menu anymore.
I waited expecting it to return to normal soon.
But since the display is still bugged I decided to make a post about it after not finding any other report about this issue so far.

Can someone help me?

This is the problem I have:

Just as a quick try did you WIPE ALL your browser cache pertaining to supermechs especially the flash cache?
If not then give that a try it may clear it up.

If you have “Transform to Mythical” as an incomplete achievement, that will happen. :slight_smile:



Thanks, Fluxeon.
After reading your reply, I upgraded a module that was at legendary lv. 40 to mythical.
Then completed the quest and the issue was gone.

Though now the question remains why this bug exists even though it was already tested.
Kinda like indicating that TacticSoft doesn’t care about it at all.

Thanks for your reply, too.
I tried Fluxeon’s suggestion first and it worked.
So it really is just problem with the “upgrade to myth” task.

Thanks for reporting.
Sending this over to the team.
Appreciate it!

1 Like

Thanks for reporting.
We just deployed a fix for this.
If you still are having issues send me a message.

1 Like