Aaaaand... Saving

So, I guess finally i am done with this game… or at least with grinding campaign?


That is quite normal that the game wants to save the progress… After 10 minutes, however:

This is encountered both on Android and on my desktop PC… @Sarah247, @Mohadib, any ideas?
Tried to do anything, nothing worked. Cannot do shit… Cancelled the mission, reloaded the page, nothing works… After I reload the page, I get the BB mission screen, when i cancel, I lose 14 fuel, but at least I am at the workshop… But if I return to BB, SAVING starts again… It is now like 20 minutes already… and counting…

1 Like

I was stuck at saving too after I killed the boss on raid 2, when I refresh I still have to.kill him again and then it again goes to saving and hangs…keeps repeating until I quit

Just noticed another post

I already quit twice, lost 28 fuel, not going to do anything until the TS team speaks a word… Quitting does not solve the problem, because if I start grinding, Saving comes back…

Maybe I didn’t try quitting I just closed the game lol

It’s for a good reason, seems they are trying to fix the HP cheat.

I do not know what you are implying, @KilliN… I am not employing any cheats. I just cannot play the campaign. And I need help…

You see people with super high points in raids like this guy?
image
he got it from cheating on HP.

They are trying to get rid of this people.

OK, broh… I do not know if you noticed I am talking about BIG BOY MISSION. IT IS THE REGULAR CAMPAIGN. NOT THE RAID… I CANNOT PLAY THE CAMPAIGN.

Raid is campaign sided.

Welcome.

Hi pilots, this should be fixed now. If it happens after you read this message, please upload a new screenshot.

1 Like